Elevated errors on Multi-Sig Frontend multisig.harmony.one
Incident Report for Harmony
Resolved
This incident has been resolved.
Posted Sep 02, 2022 - 19:09 PDT
Investigating
We're experiencing an elevated level of errors on multisig.harmony.one and are currently looking into the issue.
Posted Sep 02, 2022 - 19:08 PDT
This incident affected: Multi-Sig (Multi-Sig Frontend).