Elevated errors on Horizon frontend bridge.harmony.one

Incident Report for Harmony

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 15:47 PDT

Investigating

We're experiencing an elevated level of errors on bridge.harmony.one and are currently looking into the issue.
Posted Jun 02, 2025 - 15:46 PDT
This incident affected: Horizon (Bridge) (Horizon Frontend).