Elevated errors on Multi-Sig Backend multisig.t.hmny.io
Incident Report for Harmony
Resolved
This incident has been resolved.
Posted Aug 03, 2022 - 03:29 PDT
Investigating
We're experiencing an elevated level of errors on multisig.t.hmny.io and are currently looking into the issue.
Posted Aug 03, 2022 - 03:27 PDT
This incident affected: Multi-Sig (Multi-Sig Backend).